読者です 読者をやめる 読者になる 読者になる

Railsバージョンダウン

Rails

Rails1.2.4以上だとURLのパラメータ、POSTのパラメータによるセッションIDの受け渡しはできなくなる
1.2.6から1.2.3にバージョンダウン

config/environment.rb line:8

RAILS_GEM_VERSION = '1.2.6' unless defined? RAILS_GEM_VERSION

上記の記述があるので使用するRailsのバージョンを記載
更新したらrake rails:update:configsで更新する

rakeコマンドは特にエラー吐かなかったけれど変更が反映されないので1.2.6をアンインストールすることに。

gem to uninstall:
1. rails-1.2.3
2. rails-1.2.6
3. All versions
> 2

2を選択することによって1.2.6をアンインストールすることができます。

gem list rails
*** LOCAL GEMS ***

rails (1.2.3)
    Web-application framework with template engine, control-flow layer,
    and ORM.

自動的に1.2.3での動作に切り替わります。config/environment.rbも合わせておきます。