読者です 読者をやめる 読者になる 読者になる

Google chart toolsをRubyで使うためのwrapper

Ruby

Google chart toolsを使いたくてwrapperを探していたらgooglechartsというgemに出会って
GETパラメータに値渡してリクエストするだけでグラフが作成される!と喜んでいたのですが
Google chart toolsのdocumentと色々違うので悩んでいたのですね。

ちなみに使う時はGemfileにこんなふうに書けばGchartが使えます。

gem 'googlecharts', require: 'gchart'

理由がわかってgooglechartsがラップしている物は現在のGoogle chart toolsではなくて
かつてGoogle chart toolsと呼ばれていた現Image Chartsだったんですね。
Image Chartsは2012年4月に非推奨になっていますしなるべく使用を避けたほうがよさそうです。


そこで、現在のGoogle chart toolsのwrapperを探していたらgoogle_visualrに出会いました。

GoogleVisualrのリファレンスサイトを見る限りSVGで出力された現Google chart toolsの
グラフが表示されたのでこれを使えばいいのかなと思っています。

参考サイト