読者です 読者をやめる 読者になる 読者になる

Rails4.2からNokogiriに依存するようになってた

Rails Ruby

Rails4.1からRails4.2にバージョン上げようとGemfile修正してbundle update叩いたらNokogiriのインストールでこけた。
確かにNokogiriをインストール準備はしてないから落ちるのはわかるんだけどいつから依存するようになったの?

答えは4.2から。HTMLサニタイザのベースとしてNokogiriを使っているようだ。
Ruby on Rails 4.2 リリースノート — Rails ガイド#HTMLサニタイザ
Ruby on Rails 4.2 Release Notes — Ruby on Rails Guides#HTML Sanitizer